平成30/ 2018-10-20 06:03
HTTP/2, 2018.10.03

( apache のバージョン )
Apache.2.4.17

mod_http2
モジュールを組み込むと、http2 が利用できるようになる。
しかし、
CentOS.7.5 の Apache は、
Apache.2.4.6


( openssl のバージョン )
openssl.1.0.2
以上が必要。


Chrome、Firefox でTLS通信でしか HTTP/2 が利用できない。つまり、HTTP/2を使うには、SSLが必須。
(
https://www.sakurasaku-labo.jp/blogs/http2-beginners#index01-02
(
HTTP/2ではHTTPS通信が必須
厳密に言うと、HTTP/2ではTLS(SSL)による暗号化通信は必須ではありませんが、GoogleChromeやFirefoxでは、TLSで暗号化したHTTPSの通信でしかHTTP/2を利用できません。
従って、サイトをHTTP/2に対応させるには、実質TLS(SSL)暗号化通信が必須となります。「HTTP/2を利用する場合、ブラウザ側の仕様によりHTTPS通信にせざるを得ない」ということです。
)
)